" />
侧边栏壁纸
  • 累计撰写 13 篇文章
  • 累计创建 10 个标签
  • 累计收到 5 条评论

目 录CONTENT

文章目录

配置小型网络WLAN基本业务示例

Jhl
Jhl
2023-12-01 / 0 评论 / 2 点赞 / 57 阅读 / 13820 字 / 正在检测是否收录...

组网需求

如图所示,AC直接与AP连接。现某企业分支机构为了保证工作人员可以随时随地的访问公司网络,需要通过部署WLAN基本业务实现移动办公。

具体要求如下:

  • 提供名为“WiFi”的无线网络。

  • 工作人员分配到的IP地址网段为192.168.1.0/24。

  • AC组网方式:直连二层组网。

  • DHCP部署方式:AC作为DHCP服务器为AP和STA分配IP地址。

  • 业务数据转发方式:隧道转发。

wlan-1.png

数据规划

配置项

数据

DHCP服务器

AC作为DHCP服务器为STA和AP分配IP地址

AP的IP地址池

172.16.1.2~172.16.1.254/24

STA的IP地址池

192.168.1.2~192.168.1.254/24

AC的源接口IP地址

VLANIF10:172.16.1.1/24

AP组

  • 名称:ap

  • 引用模板:VAP模板ap、域管理模板ap

域管理模板

  • 名称:ap

  • 国家码:CN

SSID模板

  • 名称:ap-ssid

  • SSID名称:WiFi

安全模板

  • 名称:ap-security

  • 安全策略:WPA2+PSK+AES

  • 密码:ap123456

VAP模板

  • 名称:ap-vap

  • 转发模式:隧道转发

  • 业务VLAN:VLAN20

  • 引用模板:SSID模板ap-ssid、安全模板ap-security

配置思路

采用如下的思路配置小型网络的WLAN基本业务:

  1. 配置AP、AC和上层网络设备之间实现二层互通。

  2. 配置AC作为DHCP服务器为STA和AP分配IP地址。

  3. 配置AP上线。

    1. 创建AP组,用于将需要进行相同配置的AP都加入到AP组,实现统一配置。

    2. 配置AC的系统参数,包括国家码、AC与AP之间通信的源接口。

    3. 配置AP上线的认证方式并离线导入AP,实现AP正常上线。

  4. 配置WLAN业务参数,实现STA访问WLAN网络功能。

操作步骤

配置AC,使AP与AC之间能够传输CAPWAP报文

配置AC,将接口GE0/0/2加入VLAN10(管理VLAN)

<AC6605>system-view
[AC6605]sysname AC

[AC]vlan batch 10

[AC]interface GigabitEthernet 0/0/2
[AC-GigabitEthernet0/0/2]port link-type trunk 
[AC-GigabitEthernet0/0/2]port trunk allow-pass vlan 10
[AC-GigabitEthernet0/0/2]port trunk pvid vlan 10
[AC-GigabitEthernet0/0/2]quit

配置AC与上层网络设备互通

说明:根据实际组网情况在AC上行口配置业务VLAN透传,和上行网络设备互通

配置AC上行接口GE0/0/1加入VLAN20(业务VLAN)

[AC]vlan batch 20

[AC]interface gigabitethernet 0/0/1
[AC-GigabitEthernet0/0/1]port link-type trunk
[AC-GigabitEthernet0/0/1]port trunk allow-pass vlan 20
[AC-GigabitEthernet0/0/1]quit

配置AC作为DHCP服务器,为STA和AP分配IP地址

配置基于接口地址池的DHCP服务器,其中,VLANIF10接口为AP提供IP地址,VLANIF20为STA提供IP地址

[AC]dhcp enable

[AC]interface vlanif 10
[AC-Vlanif10]ip address 172.16.1.1 24
[AC-Vlanif10]dhcp select interface
[AC-Vlanif10]quit

[AC]interface vlanif 20
[AC-Vlanif20]ip address 192.168.1.1 24
[AC-Vlanif20]dhcp select interface
[AC-Vlanif20]quit

配置AP上线

创建AP组

#用于从系统视图进入WLAN视图
[AC]wlan

#创建AP组,并进入AP组视图,若AP组已存在则直接进入AP组视图
[AC-wlan-view]ap-group name ap
[AC-wlan-ap-group-ap]quit

创建域管理模板

#创建域管理模板,并进入模板视图,若模板已存在则直接进入模板视图
[AC-wlan-view]regulatory-domain-profile name ap
#配置设备的国家码标识
[AC-wlan-regulate-domain-ap]country-code cn
[AC-wlan-regulate-domain-ap]quit

[AC-wlan-view]ap-group name ap
#将指定的域管理模板引用到AP或AP组
[AC-wlan-ap-group-ap]regulatory-domain-profile ap
Warning: Modifying the country code will clear channel, power and antenna gain c
onfigurations of the radio and reset the AP. Continue?[Y/N]:y
[AC-wlan-ap-group-ap]quit

配置AC的源接口

#配置AC与AP建立CAPWAP隧道的源接口
[AC]capwap source interface vlanif 10

在AC上离线导入AP

[AC]wlan
#配置AP认证模式。如果之前没有修改其缺省配置,可以不用执行ap auth-mode mac-auth命令
[AC-wlan-view]ap auth-mode mac-auth
#离线增加AP设备或进入AP视图。增加AP时,如果AP认证模式是MAC认证,必须输入AP的MAC地址,如果AP认证模式是SN认证,则必须输入AP的SN序列号
[AC-wlan-view]ap-id 0 ap-mac 00e0-fc1a-5090
#配置单个AP的名称	
[AC-wlan-ap-0]ap-name ap
#配置AP所加入的组。每个AP都必须加入到一个AP组中,如果不配置AP加入的AP组,则AP会自动加入到名为“default”的AP组中
[AC-wlan-ap-0]ap-group ap
Warning: This operation may cause AP reset. If the country code changes, it will
 clear channel, power and antenna gain configurations of the radio, Whether to c
ontinue? [Y/N]:y
Info: This operation may take a few seconds. Please wait for a moment.. done.
[AC-wlan-ap-0]quit

查看AP1是否上线

将AP上电后,当执行命令display ap all查看到AP的“State”字段为“nor”时,表示AP正常上线

[AC-wlan-view]display ap all
Info: This operation may take a few seconds. Please wait for a moment.done.
Total AP information:
nor  : normal          [1]
-----------------------------------------------------------------------------
ID   MAC            Name Group IP           Type            State STA Uptime
-----------------------------------------------------------------------------
0    00e0-fc1a-5090 ap   ap    172.16.1.241 AP3030DN        nor   0   3M:3S
-----------------------------------------------------------------------------
Total: 1
[AC-wlan-view]

配置WLAN业务参数

配置安全模板

#创建安全模板或者进入安全模板视图,若模板已存在则直接进入模板视图
[AC-wlan-view]security-profile name ap-security
#配置WPA/WPA2的预共享密钥认证和加密
[AC-wlan-sec-prof-ap-security]security wpa2 psk pass-phrase ap123456 aes
[AC-wlan-sec-prof-ap-security]quit

配置SSID模板

#创建SSID模板,并进入模板视图,若模板已存在则直接进入模板视图
[AC-wlan-view]ssid-profile name ap-ssid
#配置当前SSID模板中的服务组合识别码SSID。配置含中文字符的SSID时,如果要修改已输入的SSID,不能使用删除键删除字符,否则配置后SSID会显示乱码,应重新执行命令ssid配置SSID。

[AC-wlan-ssid-prof-ap-ssid]ssid WiFi
[AC-wlan-ssid-prof-ap-ssid]quit

配置VAP模板

#创建VAP模板,并进入模板视图,若模板已存在则直接进入模板视图
[AC-wlan-view]vap-profile name ap-vap
#配置VAP模板下的数据转发方式
[AC-wlan-vap-prof-ap-vap]forward-mode tunnel
#配置VAP的业务VLAN。VAP下可以指定单个VLAN作为业务VLAN,也可以指定VLAN pool,VLAN pool中的所有VLAN都可以作为业务VLAN。VAP下发给AP的二层业务数据报文中都会带有业务VLAN的VLAN ID
[AC-wlan-vap-prof-ap-vap]service-vlan vlan-id 20
#在指定VAP模板中引用安全模板
[AC-wlan-vap-prof-ap-vap]security-profile ap-security
#在指定的SSID模板引用到VAP模板
[AC-wlan-vap-prof-ap-vap]ssid-profile ap-ssid
[AC-wlan-vap-prof-ap-vap]quit

配置AP组引用VAP模板

[AC-wlan-view]ap-group name ap
#在指定的VAP模板引用到射频
[AC-wlan-ap-group-ap]vap-profile ap-vap wlan 1 radio 0
[AC-wlan-ap-group-ap]vap-profile ap-vap wlan 1 radio 1

效果图—初次上线

wlan-2.png

配置AP射频的信道和功率—选配

举例中AP射频的信道和功率仅为示例,实际配置中请根据AP的国家码和网规结果进行配置。

关闭射频的信道和功率自动调优功能

#创建RRM模板并进入RRM模板视图
[AC-wlan-view]rrm-profile name default
#关闭信道自动选择功能
[AC-wlan-rrm-prof-default]calibrate auto-channel-select disable
#关闭信道自动选择功能
[AC-wlan-rrm-prof-default]calibrate auto-txpower-select disable
[AC-wlan-rrm-prof-default]quit

配置AP射频0的信道和功率

[AC-wlan-view]ap-id 0
#进入射频视图
[AC-wlan-ap-0]radio 0
#配置单个AP指定射频的工作带宽和信道
[AC-wlan-radio-0/0]channel 20mhz 12
Warning: This action may cause service interruption. Continue?[Y/N]y
#配置单个AP指定射频的发射功率
[AC-wlan-radio-0/0]eirp 127
[AC-wlan-radio-0/0]quit

配置AP射频1的信道和功率

[AC-wlan-ap-0]radio 1
[AC-wlan-radio-0/1]channel 20mhz 161
Warning: This action may cause service interruption. Continue?[Y/N]y
[AC-wlan-radio-0/1]eirp 127
[AC-wlan-radio-0/0]

效果图—调整信道后

验证配置结果

WLAN业务下发

WLAN业务配置会自动下发给AP,配置完成后,通过执行命令display vap ssid WiFi查看如下信息,当“Status”项显示为“ON”时,表示AP对应的射频上的VAP已创建成功。

[AC-wlan-view]display vap ssid WiFi
Info: This operation may take a few seconds, please wait.
WID : WLAN ID            
----------------------------------------------------------------------
AP ID AP name RfID WID  BSSID          Status  Auth type  STA   SSID
----------------------------------------------------------------------
0     ap      0    1    00E0-FC1A-5090 ON      WPA2-PSK   1     WiFi
0     ap      1    1    00E0-FC1A-50A0 ON      WPA2-PSK   1     WiFi
----------------------------------------------------------------------
Total: 2

STA上线

STA搜索到名为“WiFi”的无线网络,输入密码“ap123456”并正常关联后,在AC上执行display station ssid WiFi命令,可以查看到用户已经接入到无线网络“WiFi”中。

[AC-wlan-view]display station ssid WiFi
Rf/WLAN: Radio ID/WLAN ID                                                     
Rx/Tx: link receive rate/link transmit rate(Mbps)                             
-------------------------------------------------------------------------------------------
STA MAC          AP ID Ap name  Rf/WLAN  Band  Type  Rx/Tx      RSSI  VLAN  IP address
-------------------------------------------------------------------------------------------
5489-9819-4eaa   0     ap       0/1      2.4G  -     -/-        -     20    192.168.1.230
5489-9853-75db   0     ap       1/1      5G    11a   0/0        -     20    192.168.1.118
-------------------------------------------------------------------------------------------
Total: 2 2.4G: 1 5G: 1

效果图—SAT上线成功

wlan-3.png

2

评论区